Follow Herb Miller on Facebook Follow Herb Miller on Twitter Follow Herb Miller on LinkedIn Follow Herb Miller on GooglePlus Follow Herb Miller on YouTube

Xandrien Thiel

I sent my website address to a lot of friends and asked feedback.I already got some good tips. And a lot of enthusiastic remarks as well. Xandrien Thiel www.balancingbyart.com

read more

Lesley Hussell

Herb is a WordPress genius, creating websites that are simple to use and do whatever the customer needs. Nothing is too much trouble – he takes great pains to make sure you understand what he's doig so you can do it too, avoids geek-speak although he's a tech wizard, and is patient and meticulous. He's a total WordPress zealot and knows countless tricks and widgets. His prices are very affordable and represent excellent value for money. An all-round good guy. Lesley Hussell - www.editingedge.co.uk

read more

Classic Car Doctor

Everyone thinks the site is great. Really professional. I've already got two new customers... one from the Bahamas. Dave the Classic Car Doctor www.classic-car-doctor.com

read more

Dave Carson

I hired Herb to transform my website to WordPress. He did this for me and at the same time totally transformed my website. He has done a fantastic job and not forgetting the time he put in helping me understand how to use my new website. I would definitely recommend Herb to anyone who wants to work with someone who knows what they're talking about and who does such a brilliant job. Thank you Herb and keep up the great work. David Carson www.pcs-uk.co.uk

read more

Morning campers. I have a request for assistance. It’s to do with my oik plugin (oik).

On this site www.Bobbing Widewebdesign.com when I enable either the oik-bwtrace or oik base plugin then slideshow-gallery-pro stops displaying the slideshow.

Hope you can help.

slideshow should go here

Ooh look – it’s working. Thanks to ben huson for proving the old adage

given enough eyes every problem is shallow

See below for the solution.


[gpslideshow]


Use your preferred browser to inspect the HTML that’s been generated. You should see 6 images in a hidden list and some jquery code to do the cycling. But there’s something wrong and it doesn’t work!

problem determination performed so far

Is the problem reproducable?

Yes, but only on this site. When I deactivate my oik-bw-trace or oik base plugin then the slideshow cycles properly.

Can you reproduce it locally?

No? It works fine on my local (Windows) install

Can you reproduce it on other Linux installs?

No. It works fine on other sites – see http://twenty-tens.co.uk/sgp-oik

Have you compared working and non-working pages?

Yes. Using Google chrome I viewed source and saved the HTML then compared using BeyondCompare.

There were a couple of differences that didn’t make sense. Some of the XHTML was not properly formed. bad ending tags…

we’ll come back to this later.

Have you disabled / paused JavaScript and compared pages?

No, I don’t know how to.

Are versions the same on different sites?

Yes. WordPress 3.2.1, oik v0.7, slideshow gallery pro v 1.4.1 and my theme is bwdesign0715.

Have you deactivated other plugins?

I don’t want to fiddle too much with Bobbing Widewebdesign.com so instead I installed the same plugins on another site and hoped it would wrong. Post Scriptum: It still works on the other site with the same set of plugins.

Why are your links so dim?

and did you know you’ve got a broken image in the right sidebar and two images which seem a bit too big.

Yes, thanks. There are many more fobs and bongs to fix.

fob bong oik – WTF?

For more information on fob, bong and hide see www.fobbonghide.com

For more information on oik see oik

Does it work on a page?

No. See this message duplicated on a single page 

What plugins are activated?

See plugins I’m using on Bobbing Wide web design.com

have you uninstalled and reinstalled?

Yes, it didn’t make any difference.

Are there any rogue files?

ie. Are there files that are not part of the plugins that are somehow intercepting the processing.

No. It’s happened before but not this time.

Is the HTML good?

When we looked at the generated HTML again we saw some jQuery code that appeared to be embedded  into a menu item… nowhere near the code that wasn’t working. Then Ben noted that I’d included the shortcode in a page title. oops! 

USER ERROR!! problem solved.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>